覚え書-#18。

投稿アップデート情報  追記(8/28)
  1. PHP 5.6.0 GA の正式リリースの時期が, RC4 の記事に書いてあった。とーっても楽しみ。 wow!
  2. Apache 2.4.10 (httpd-2.4.10-win32-VC11.zip) を openssl-1.0.1i のものに,アップデートした。 OpenSSL Security Advisory [6 Aug 2014] のせいなんだが, Steffen が Jan-E に “Coming days the builds here at Apache Lounge are going to be upgraded. It has not that priority and severity ~” と回答していたので,焦らずに待っていたのだ。
  3. Windows Update 2014 年 8 月はトラブル続出だったみたいだね。うちのパソコンは幸いにも1台も引っかからなかったんだが,現時点で特に問題がなくても KB2982791, KB2970228, KB2975719 and KB2975331 をアンインストールしたほうがいいということらしいので,探し出してアンインストールした。以下の通り。
    • NJ2100 上の Windows8.1(x86)
      KB2982791
      KB2975719
    • CF-J10 上の Windows7 SP1(x64)
      KB2982791
      KB2970228
    • xw4200 上の Windows7 SP1(x86)
      KB2982791
      KB2970228
    • KeyPaso 上の Windows Vista SP2(x86)
      KB2982791

    昔は, Windows update というとほぼ毎回不具合があって,少し落ち着くまで更新を控えたりしたものだが,今回のドタバタは久しぶりだった気がする。皆さんはどう思われますか? (^_~)

追記(8/28):
 MS14-045 関連の不具合更新プログラム, KB2993651 が出てますな。詳しくは,[MS14-045] 更新プログラム 2982791 の問題を解決する更新プログラム 2993651 を公開

「覚え書-#18。」への6件のフィードバック

  1. おはようございます。

    やっとphp5.6なのかな。触るのは楽しみですね。
    触りすぎると消化不良になりますけど・・・。
    SNIという技術を使いipアドレス一個で複数のsslサイトを公開できると知ったのでsuperweibu.netをstartsslで常時ssl化。
    nginxは成功したんですが、apache2.2はうまくいきませんね。
    消化不良の胸焼け中です。
    また挑戦しようかなと思います。

    windowsupdateですが、windowsサーバーを触っていたときは自動アップデータを切ってセカンダリーからバージョンアップして問題なければプライマリーという感じでupdateしてました。

    1. くりくりさん,こんにちは。

      > やっとphp5.6なのかな。触るのは楽しみですね。
      ですね。WordPressもまだ完全に5.6に対応しているかどうか定かでないので,なんか不都合の起こる可能性もありますが。

      > apache2.2はうまくいきませんね。
      いろいろ条件があるようですが,その辺はどうなんでしょうか。すでにご覧でしょうが,SSLStrictSNIVHostCheck DirectiveとかNameBasedSSLVHostsWithSNIが見つかりました。NameBasedSSLVHostsWithSNIのPrerequisites to use SNIのところには,ApacheでSNIが使えるための要件が書いてありますね。クライアントのほうの条件もあるんでしょうね。

      > セカンダリーからバージョンアップして問題なければプライマリー
      昔はサーバでなくても,そういう感じでやってましたね。今後も必要なのかな。今回は全台大丈夫だったけど,全台アウトっていう悲惨なことも考えられるし……

  2. おはようございます。

    そちらは物凄い大雨みたいですが
    大丈夫でしょうか?
    http://headlines.yahoo.co.jp/hl?a=20140822-00010000-wmap-soci

    なにかありましたら、早めの避難行動を。

    >いろいろ条件
    ありがとうございます。mod_gnutlsこんなモジュールがあったとは!!やっぱり誰かに相談してみるもんですね。
    自分の視野がせまくなってしまいます。

    1. くりくりさん,こんばんは。

      > 大丈夫でしょうか?
      ありがとうございます。朝いただいていましたのに,気づきませんで失礼しました。

      県南のほうは大変だったようですが,うちのあたりは,幸い,朝方少し降っただけでした。

      広島のほうはまた降ったみたいですね。二次災害とか,大丈夫だったのでしょうか。みなさま,お気を付け下さいませ。

    1. くりくりさん,こんにちは。

      おめでとうございます。
      しかし,SNIは実務で使うとなるとまだ厳しいところがあるのかもしれません。
      クライアントのほうの大問題だった XP は虹のかなたに消えましたが(笑)。

      新し物好きの私は,ついつい忘れているんですが, OpenSSL だってまだまだ 0.9.8 系を使っているところもあったりするし, Apache のバージョンだっていまだにとんでもなく前のもののところもあります。

      そうはいっても,そっちの方向に動いていくのは間違いないんでしょうねぇ。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください