覚え書-#31。

投稿アップデート情報  追記(7/21)

 チョコチョコとサーバソフトのアップデートをした。

  1. ActivePerl-5.22.1.2201 から ActivePerl-5.24.0.2400 に。
    ActivePerl-5.22.1.2201-MSWin32-x86-64int-299574.msi をインストールしてたんだが,今回から msi 形式がなくなっていたので, ActivePerl-5.24.0.2400-MSWin32-x86-64int-300558.exe をインストールしようとしたのだが,下記のエラーが出てうまくいかなかった。

    Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.  Action CheckInstallDir, entry: CheckInstallDirNoBox, library: C:\Users\UserID\AppData\Local\Temp\MSIXXXX.tmp

    そんなわけで, ActivePerl-5.24.0.2400-MSWin32-x86-64int-300558.zip を手動でインストール。これは,ちゃんと動いている。で,上記の問題は, Bug 107209 として報告した。
    バグの直った ActivePerl-5.24.0.2400-MSWin32-x86-64int-300560.exe が出た。 (2016.7.21)

  2. PHP7.0.7 から PHP7.0.8 に (php-7.0.8-Win32-VC14-x86.zip)。
    php.ini について,もっと詳しい情報をという方は,「本家のお世話-#109。(PHP 5.5.16 から PHP 5.6.0 への移行)」をご覧ください。
    ところで, php.ini から APCu 関連項目を削除した。

    extension=php_apcu.dll
    
    [apcu]
    apc.enabled=1
    apc.shm_size=256M
    apc.writable="C:\Users\UserID\AppData\Local\Temp"

    新バージョンが出ていたので, APCu 5.1.4 からアップデートしたかったのだが……それというのが,ここのところ, VirtualAlloc() がらみのエラーで手を焼いていて, APCu に関連あるかも(まったくの勘違いの可能性のほうが大きいが)と思ったので, version 5.1.5 を見に行ったら,なんと ts-vc14-x86.zip がなかったのだ。

  3. phpMyAdmin-4.6.2 から phpMyAdmin-4.6.3 に。
  4. MariaDB は,一度, 10.1.15 にしたのだが,下記のようなことらしいので, 10.1.14 に戻した。
    MariaDB-10.1.15 was never released.
    Queries examines all rows of a tables when it should not
  5. Apache2.4.20 から Apache2.4.23 (httpd-2.4.23-win32-VC14.zip) に。
    mod_proxy_http2.so という新モジュールが追加されていた。 2.4.21 と 2.4.22 は結局出ないままだった。

「覚え書-#31。」への16件のフィードバック

  1. こんばんは

    あれ、mariadbがw
    バックアップとってダウングレードしよ・・・。

    そして、apacheは最近欠番おおいですね。
    mod_proxyかhttp/2のみにして大丈夫なんですかね?
    それにchagelogがおおそう・・・。
    こういうので思い出すが、ある中学校は中間テストが無く期末試験しかないところがあったんですよ。うらやましいなと思う半分。試験範囲がひろそうなんでそれはそれで嫌そうでしたね。

    最近サーバーはほとんど触っていません。
    コードばかり書いています。
    sublime text が結構つかえるのでコードのうち間違い多少減りそうです。

    1. くりくりさん,こんばんは。

      > あれ、mariadbがw
      はい,そうなんです。この件,メールでお知らせしようかとも思ったのですが,記事に書いたほうがかえって早いかと,夕べ頑張ってこの覚え書を書きました。記事の公開は,結局, 7/6 になってしまいましたが(苦々々)。

      > mod_proxyかhttp/2のみにして大丈夫なんですかね?
      どうでしようかねぇ。またもや「This module is experimental.」ですが。とはいっても,公式のコアに入ったくらいですから,そこそこには使えるんでしょう。

      > sublime text が結構つかえる
      Sublime Text はテキストエディタなんですね。 IDE(Integrated Development Environment) ということではないようですが,こういうソフトの補完機能って便利ですよねぇ。ほんと助かります。

  2. こんにちは

    mariadbのダウングレード終りました。
    パッケージでいれてるからfail2banとかpostfixも影響うけちゃってこれらも削除後最インストールです。
    こういうのがパッケージは面倒ですね。

    > IDE
    最近この手の開発環境をしりました。vimで色々出来るみたいですが、こちらはその内なれはじめたら挑戦してみるつもりです。まずはコードを遅くてもいいから間違えないように丁寧にかかないと・・。

    >apache
    http://jvn.jp/vu/JVNVU97485903/

    前のバージョンは認証の問題があったみたいです。
    最近はapacheの名前つかってる物で脆弱性が多いから
    見過ごしてました。紛らわしい。

    1. くりくりさん,こんにちは。

      MariaDB ,おつかれさまでした。

      > http://jvn.jp/vu/JVNVU97485903/
      これ, CVE-2016-4979 の件ですね。 HTTP/2 関連なので気づいていなければいけなかったのですが,気づいてませんでした。 ChangeLog を見ると, 21 – 23 でものすごくたくさんありますよねぇ。このあたりが, 21, 22 が出ずに, 23 も手間取った原因かもしれません。

  3. おはようございます。

    そちらは大雨みたいですが大丈夫でしょうか?
    うちは雨がなく本格的にやばくなりそうです。
    もっとこっちに降ってくれればいいのに。

    そして、やっとiphoneがきました。
    ネットで調べると俺より早く入荷したとの書き込みが多く。
    他の店に在庫があるようならキャンセルしようと思って
    探していたら入荷の連絡です。

    1. くりくりさん,こんにちは。

      雨は,大丈夫そうです。しかし,暑くなったり寒くなったりが激しくて,体がついていきません。溜息。

      > やっとiphoneがきました。
      iPhone SE でしたよね。期待通りの点が多いといいですね。

      ところで,ついに, PHP5.5 EOL が来ちゃいましたねぇ。この間話したような気がしますが,早いものです。

  4. おはようございます。

    >PHP5.5 EOL

    opcacheが初めて導入されてphp高速化の有効な手段だったんですが、会社サーバーでopcacheを導入できてるのは2台のみに(w 移転のめどがたたなくなったので移転予定だったサーバーを5.5から5.3に戻しましたよ。

    5.3に戻したらwpで使えないプラグインがでてきてるみたいですが、自業自得でおれはしらねという状態です(w

    それに7.1のアルファがでていますしそちらに期待です。

    1. くりくりさん,こんにちは。

      > 5.5から5.3に戻しましたよ。
      CentOS6 上のということですか?お疲れさまです。まぁ, CentOS6 の EOL は RHEL6 と同じでしょうから, 2020.11.30 までは問題ないでしょうが,「wpで使えないプラグイン」なんて言うところで困りますよねぇ。

      そういえば,今月の Windows Update どうでしたか?うちは,無事に済みました。
      Adobe Flash Player および Adobe Acrobat Reader も,なんだかシビアなのが来てるみたいです。レートが critical になっていました。
      Adobe Flash Player については,現時点(13:30)で, Google Chrome だけアップデートが来ていません。 Chrome 本体はアップデートがあって 51.0.2704.106 m になったんですが, Flash Player は間に合わなかったんでしょうか。 Adobe Acrobat Reader は,多分,マニュアルアップデートですね。

  5. こんにちは
    なんか今日はだるくてなんもやるきがしないです。

    >CentOS6 上のということですか?
    CentOS5です。

    6は一年間借りただけでmysqlがこわれたので消えました。7と5しかありません。

    >今月の Windows Update どうでしたか?
    昨日の書き込みの後、readerもwindosもplayerも
    アップデータしました。

    >Acrobat Reader は,多分,マニュアルアップデート
    なるほど、結構時間かかったのはそういうことなんですかね。

    そして、vpsなんですがgmoクラウドにまた戻そうかなと考えています。ipv6のアクセス全然ないしやっている意味がないような・・・。

    1. くりくりさん,こんにちは。

      > 今日はだるくてなんもやるきがしないです。
      大丈夫ですか?温度・湿度共に高くなってきたので,熱中症等,お気を付けください。

      > CentOS5です。
      EEOL が, CentOS6 のEOL と同じですね。しばらくは対処の時間が取れますね。

      > 昨日の書き込みの後、readerもwindosもplayerも
      > アップデータしました。
      うちは, Google Chrome の Adobe Flash Player のバージョンがいまだに 22,0,0,192 なんですが,手動でやらないといけませんかね。今回の分はレートが critical だったので,少し気になります。

      > ipv6のアクセス全然ないしやっている意味がないような・・・。
      そうなんですか。 IPv6 の方が HTTPS より普及に手間取るのかもしれませんねぇ。うちもこちらの方は旧態依然ですし(苦笑)。

  6. こんにちは

    モニター壊れてしまったのですか?
    早く直るといいですね。

    >大丈夫ですか?
    いつものサボり癖です(w
    失礼しました。

    let`s encryptの更新失敗しました。
    エラーは

    The program nginx (process ID 24858) is already listening on TCP port 80. This
    will prevent us from binding to that port. Please stop the nginx program

    ということでスクリプトを変更
    サーバー止める→証明書の更新→サーバースタート
    これでうまくいきました。

    今、apacheとphpをコードからインストールしようと色々やっているのですが、configureに--enable-opcacheがなかったりどうなってるんだこれw

    1. くりくりさん,こんにちは。

      > モニター壊れてしまったのですか?
      もう,寿命なのかも知れませんが,時間を見つけて,悪あがきしてみるつもりです(笑)。

      > サーバー止める→証明書の更新→サーバースタート
      やはり,サーバを止めないといけないのですか?導入のときも,何かそんなことを書かれていませんでしたっけ。

      > configureに--enable-opcacheがなかったり
      指定したらエラーが出るということですか?

      ところで,一昨日の関東地方はところによってはかなりの雨だったようですが,くりくりさんのところはいかがでしたか?

  7. 今晩は
    やっぱり色々やってみるものですな。
    モニターがうつるようになってよかったです。

    俺はapacheとphpのインストール先をrpmと同じようにしようと苦戦中でしたが、ようやくインストールできました(w

    今はapache2.4のhttp/2に挑戦中。だけどこれ最新のopensslをインストールしないと駄目とは知りませんでした。nginxはコードだけでインストールする必要はないです。

    >指定したらエラーが出るということですか?
    エラーにはなりません。オプションを指定しなくても勝手にインストールされるみたいです。下記はphp -vの出力結果です。有効になっています。

    with Zend OPcache v7.0.8, Copyright (c) 1999-2016, by Zend Technologies
    [root@ik1-321-20601 httpd-2.4.23]#

    >くりくりさんのところはいかがでしたか?
    ほとんど降りませんでした。千葉がひどかったみたいです。利根川水系のダムにふってほしいのです。

    追記、証明書の更新はサーバー止めないで更新できサーバーの再起動だけを行えばいいとどこかで読んだのでそのようにしたんです。でも駄目でした。

    1. くりくりさん,おはようございます。

      > エラーにはなりません。オプションを指定しなくても
      > 勝手にインストールされるみたいです。
      改めて, --enable-opcache のところを読み返してみましたが,デフォルトで有効になってるような感じですね。 --disable-all を指定した場合に限り --enable-opcache を使ってくださいとありますから。

      > サーバー止めないで更新できサーバーの再起動だけを行えばいい
      これじゃないですか?
      我が家は未だにリニューアルの方法を模索していますが,少し目鼻がついてきました。このままうまくいけばいいんですけどねぇ。

      > 利根川水系のダムにふってほしいのです。
      降ってほしいところには,なかなか降りません。でも,今のところ,我が家のあたりも,くりくりさんのところも,とんでもない状況まで行ってはいませんから,良しとすべきですかねぇ。

  8. こんにちは

    mariadb10.1.16が来ました。
    さて、コードからapacheとphpをインストールしていますが
    エラーの連続できついです。
    やっとhttp/2とwordpressをインストールできるまで来ました。
    これで後はmuninとawstatsがepelレポからインストールして問題なければサーバーのお引越しにうつれそうです。

    1. くりくりさん,こんばんは。

      暑いです(笑)。うちのあたり,昨日,梅雨明け宣言がありまして,本日は宣言通りの「梅雨明け十日」真っ只中の晴天でした。昨日から,素麺解禁です(爆笑)。 3 食食べてます。なんせ,庭の茗荷が食べられるようにならないと,解禁にしない人なもんで。当然,他の人用には, 3 食は無理なんですけどね。 3 食続けて,素麺を食べさせたら,総スカン食っちゃいますワ。

      来ましたねぇ。まりあちゃん 16 。連絡,ありがとうございます。この間の件もあるし,どうしようと思ったんですが,やっぱり,しちゃいました(爆)。 2 回続きはないだろうっと……ムムム。

      > コードからインストールしていますが
      頑張ってらっしゃいますねぇ。そろそろ目途が立ちそうですね。おめでとうございます。

      ところで,うちは, BIND も PROXY も使っていないので,関係ないんだろうと思っているのですが(???),記事にお書きでしたね。 PROXY の件は, Apache Lounge の Retweet で気づきました。 Apache Lounge に行ってみたら,回避策を投稿してる人がいました。 httpoxy.org に書いてあったのみたいです。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください