Updating to PHP5.4.15.

Update information      Edit(Aug.3)

   At May-08 22:51:34UTC, they released PHP5.4.15. However, on May-09, the news read:

   “Seriously: PHP 5.4.15 and PHP 5.3.25 really were released!”

  • We weren’t trying to pull an April Fool’s Day joke in May. A temporary glitch caused the latest distributions of PHP to not properly propagate to the mirror servers. This has been fixed at the root level, and it’s now being distributed to all of the mirrors. We’ll take some bacon to go with the egg on our faces, please!
  • If you continue to experience issues with downloading these versions after 21:00 UTC on 9 May, 2013, please drop us a line at php-mirrors@lists.php.net, telling us from which mirror you’re trying to download, and we’ll get it resolved.
  • We apologize for the delays and confusion this may have caused, and thank you for using PHP.

   They have had something wrong, haven’t they? Though, I don’t know about it, I’m more interested in ‘We’ll take some bacon to go with the egg on our faces, please!’.
   What does the sentence mean exactly? Yes, I can infer the meaning of the sentence from context, though. What is some bacon in the sentence really? This is very difficult for me who is NOT an everyday-English-speaker. Someone, re-write it by using less idiomatic, please, please, please!!!

   By the way, I downloaded a Thread Safe version php-5.4.15-Win32-VC9-x86.zip for my server (WindowsXP SP3(x86)).

   Acoording to the ChangeLog, it has 7 bug fixes, and upgrades libmagic to 5.14. They say “All users of PHP are encouraged to upgrade to PHP 5.4.14.”.

   As php5apache2_4.dll included in the official PHP binary 5.4.10+, I extracted the zip archive and replaced all PHP5.4.13 files with all PHP5.4.14 files except my php.ini. Then, I restarted my Apache. That’s it.

   If you need how to configure PHP5.4, please see the post on my Japanese blog. Of course, it is only in Japanese and for a mbstrings user, but I think the information gives some help for you.

Edit(Aug.3):
   If you need how to configure PHP5.5, please see “To create a Wamp-like Web Server in Windows7-#2“.